# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<prefix1>\d{0,3}?)(?<suffix1>\d{1,3})\/(?<prefix2>\d{0,3}?)(?<suffix2>\d{1,3})\/"
test_str = ("1/1/\n"
"12/1/\n"
"123/1/\n"
"1234/1/\n"
"12345/1/\n"
"123456/1/\n\n"
"1/12/\n"
"1/123/\n"
"1/1234/\n"
"1/12345/\n"
"1/123456/\n\n"
"12/12/\n"
"123/12/\n"
"1234/12/\n"
"12345/12/\n"
"123456/12/\n\n"
"12/123/\n"
"12/1234/\n"
"12/12345/\n"
"12/123456/\n\n"
"123/123/\n"
"1234/123/\n"
"12345/123/\n"
"123456/123/\n\n"
"123/1234/\n"
"123/12345/\n"
"123/123456/\n\n"
"1234/1234/\n"
"12345/1234/\n"
"123456/1234/\n\n"
"1234/12345/\n"
"1234/123456/\n\n"
"12345/12345/\n"
"123456/12345/\n\n"
"12345/123456/\n\n"
"123456/123456/\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.