use strict;
my $str = '1/1/
12/1/
123/1/
1234/1/
12345/1/
123456/1/
1/12/
1/123/
1/1234/
1/12345/
1/123456/
12/12/
123/12/
1234/12/
12345/12/
123456/12/
12/123/
12/1234/
12/12345/
12/123456/
123/123/
1234/123/
12345/123/
123456/123/
123/1234/
123/12345/
123/123456/
1234/1234/
12345/1234/
123456/1234/
1234/12345/
1234/123456/
12345/12345/
123456/12345/
12345/123456/
123456/123456/
';
my $regex = qr;(?<prefix1>\d{0,3}?)(?<suffix1>\d{1,3})\/(?<prefix2>\d{0,3}?)(?<suffix2>\d{1,3})\/;p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}