import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<prefix1>\\d{0,3}?)(?<suffix1>\\d{1,3})\\/(?<prefix2>\\d{0,3}?)(?<suffix2>\\d{1,3})\\/";
final String string = "1/1/\n"
+ "12/1/\n"
+ "123/1/\n"
+ "1234/1/\n"
+ "12345/1/\n"
+ "123456/1/\n\n"
+ "1/12/\n"
+ "1/123/\n"
+ "1/1234/\n"
+ "1/12345/\n"
+ "1/123456/\n\n"
+ "12/12/\n"
+ "123/12/\n"
+ "1234/12/\n"
+ "12345/12/\n"
+ "123456/12/\n\n"
+ "12/123/\n"
+ "12/1234/\n"
+ "12/12345/\n"
+ "12/123456/\n\n"
+ "123/123/\n"
+ "1234/123/\n"
+ "12345/123/\n"
+ "123456/123/\n\n"
+ "123/1234/\n"
+ "123/12345/\n"
+ "123/123456/\n\n"
+ "1234/1234/\n"
+ "12345/1234/\n"
+ "123456/1234/\n\n"
+ "1234/12345/\n"
+ "1234/123456/\n\n"
+ "12345/12345/\n"
+ "123456/12345/\n\n"
+ "12345/123456/\n\n"
+ "123456/123456/\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}