#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-?\d+(?:\.\d+|)(?=\s*р\.?\s+START:)"
Local $sString = "Ваш баланс: -540.20 р." & @CRLF & _
"START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#" & @CRLF & _
"" & @CRLF & _
"-540.20 р." & @CRLF & _
"START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#" & @CRLF & _
"" & @CRLF & _
"-560р" & @CRLF & _
"START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")