const regex = /-?\d+(?:\.\d+|)(?=\s*р\.?\s+START:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?\\d+(?:\\.\\d+|)(?=\\s*р\\.?\\s+START:)', 'gm')
const str = `Ваш баланс: -540.20 р.
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
-540.20 р.
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
-560р
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}