re = /-?\d+(?:\.\d+|)(?=\s*р\.?\s+START:)/m
str = 'Ваш баланс: -540.20 р.
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
-540.20 р.
START: кино и сериалы за 249.222 р./мес. Первые 14 дн ей - за 0 р: *214#
-560р
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end