import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?\\d+(?:\\.\\d+|)(?=\\s*р\\.?\\s+START:)";
final String string = "Ваш баланс: -540.20 р.\n"
+ "START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#\n\n"
+ "-540.20 р.\n"
+ "START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#\n\n"
+ "-560р\n"
+ "START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}