import Foundation
let pattern = #"-?\d+(?:\.\d+|)(?=\s*р\.?\s+START:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Ваш баланс: -540.20 р.
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
-540.20 р.
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
-560р
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)