$re = '/-?\d+(?:\.\d+|)(?=\s*р\.?\s+START:)/m';
$str = 'Ваш баланс: -540.20 р.
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
-540.20 р.
START: кино и сериалы за 249.222 р./мес. Пер вые 14 дней - за 0 р: *214#
-560р
START: кино и сериалы за 249.222 р./мес. Первые 14 дней - за 0 р: *214#
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);