# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/="([^"]*\.(?:png|jpeg|jpg|gif|bmp))"//Ui;t' <<< "position=\"left\" poster=\"imagejpg\""