const regex = /="([^"]*\.(?:png|jpeg|jpg|gif|bmp))"/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('="([^"]*\\.(?:png|jpeg|jpg|gif|bmp))"', 'i')
const str = `position="left" poster="imagejpg"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);