#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?Ui)="([^"]*\.(?:png|jpeg|jpg|gif|bmp))""
Local $sString = "position="left" poster="imagejpg""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)