import re
regex = re.compile(r"=\"([^\"]*\.(?:png|jpeg|jpg|gif|bmp))\"", flags=re.IGNORECASE)
test_str = "position=\"left\" poster=\"imagejpg\""
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)