using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=""([^""]*\.(?:png|jpeg|jpg|gif|bmp))""";
string substitution = @"";
string input = @"position=""left"" poster=""imagejpg""";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}