re = /="([^"]*\.(?:png|jpeg|jpg|gif|bmp))"/i
str = 'position="left" poster="imagejpg"'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result