package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Esta condición)?(?(1) es verdadera| es falsa)`)
var str = `Esta condición es verdadera
Esta otra es falsa
Aquí no se debe seleccionar nada`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}