const regex = /(Esta condición)?(?(1) es verdadera| es falsa)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Esta condición)?(?(1) es verdadera| es falsa)', 'g')
const str = `Esta condición es verdadera
Esta otra es falsa
Aquí no se debe seleccionar nada`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}