$re = '/(Esta condición)?(?(1) es verdadera| es falsa)/';
$str = 'Esta condición es verdadera
Esta otra es falsa
Aquí no se debe seleccionar nada';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);