#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)limit+([\s\S]+)"
Local $sString = "✔ nnn : am" & @CRLF & _
"-limitaaaa" & @CRLF & _
"ça UNICODE HERE" & @CRLF & _
"sdasdsadaw" & @CRLF & _
"✔ UNICODE HERE" & @CRLF & _
"limitaaaa,.@#!~`%$&*()[]{}|\+=-_?/'":;.><," & @CRLF & _
"777723xx sss fff s :,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")