$re = '/limit+([\s\S]+)/m';
$str = '✔ nnn : am
-limitaaaa
ça UNICODE HERE
sdasdsadaw
✔ UNICODE HERE
limitaaaa,.@#!~`%$&*()[]{}|\\+=-_?/\'":;.><,
777723xx sss fff s :,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);