import re
regex = re.compile(r"limit+([\s\S]+)", flags=re.MULTILINE)
test_str = ("✔ nnn : am\n"
"-limitaaaa\n"
"ça UNICODE HERE\n"
"sdasdsadaw\n"
"✔ UNICODE HERE\n"
"limitaaaa,.@#!~`%$&*()[]{}|\\+=-_?/'\":;.><,\n"
"777723xx sss fff s :,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")