import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "limit+([\\s\\S]+)";
final String string = "✔ nnn : am\n"
+ "-limitaaaa\n"
+ "ça UNICODE HERE\n"
+ "sdasdsadaw\n"
+ "✔ UNICODE HERE\n"
+ "limitaaaa,.@#!~`%$&*()[]{}|\\+=-_?/'\":;.><,\n"
+ "777723xx sss fff s :,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}