using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"limit+([\s\S]+)";
string input = @"✔ nnn : am
-limitaaaa
ça UNICODE HERE
sdasdsadaw
✔ UNICODE HERE
limitaaaa,.@#!~`%$&*()[]{}|\+=-_?/'"":;.><,
777723xx sss fff s :,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}