# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-?\d+(?:\.\d+)?|\+?(?:\d+(?:\.\d+)?|\.\d+)//gm;t' <<< "+3.14
3
3.0
+45
-34
-4.35
.5
.50
-.5
+.5"