$re = '/-?\d+(?:\.\d+)?|\+?(?:\d+(?:\.\d+)?|\.\d+)/m';
$str = '+3.14
3
3.0
+45
-34
-4.35
.5
.50
-.5
+.5';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;