use strict;
my $str = '+3.14
3
3.0
+45
-34
-4.35
.5
.50
-.5
+.5';
my $regex = qr/-?\d+(?:\.\d+)?|\+?(?:\d+(?:\.\d+)?|\.\d+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";