#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-?\d+(?:\.\d+)?|\+?(?:\d+(?:\.\d+)?|\.\d+)"
Local $sString = "+3.14" & @CRLF & _
"3" & @CRLF & _
"3.0" & @CRLF & _
"+45" & @CRLF & _
"-34" & @CRLF & _
"-4.35" & @CRLF & _
".5" & @CRLF & _
".50" & @CRLF & _
"-.5" & @CRLF & _
"+.5"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)