import Foundation
let pattern = #"-?\d+(?:\.\d+)?|\+?(?:\d+(?:\.\d+)?|\.\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+3.14
3
3.0
+45
-34
-4.35
.5
.50
-.5
+.5
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)