re = /-?\d+(?:\.\d+)?|\+?(?:\d+(?:\.\d+)?|\.\d+)/m
str = '+3.14
3
3.0
+45
-34
-4.35
.5
.50
-.5
+.5'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result