#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=(?:[A-Z]{3}\s){2})[0-9]{3}"
Local $sString = "QA 44" & @CRLF & _
"ABQ DAL 280" & @CRLF & _
"ABQ HOU 290" & @CRLF & _
"HOU PHX 210" & @CRLF & _
"DAL PHX 102"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")