use strict;
my $str = 'QA 44
ABQ DAL 280
ABQ HOU 290
HOU PHX 210
DAL PHX 102';
my $regex = qr/(?<=(?:[A-Z]{3}\s){2})[0-9]{3}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}