import re
regex = re.compile(r"(?<=(?:[A-Z]{3}\s){2})[0-9]{3}")
test_str = ("QA 44\n"
"ABQ DAL 280\n"
"ABQ HOU 290\n"
"HOU PHX 210\n"
"DAL PHX 102")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")