re = /(?<=(?:[A-Z]{3}\s){2})[0-9]{3}/
str = 'QA 44
ABQ DAL 280
ABQ HOU 290
HOU PHX 210
DAL PHX 102'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end