#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=(['"])\b)(?:(?!\1|\\).|\\.)*(?=\1)"
Local $sString = ""2005014523","34.95661","-96.74025","1","52","52","5/17/2020 - 11:10 AM","By 5/17/2020 2:38 PM","5/17/2020 - 12:50 PM","UNPLANNED""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")