import Foundation
let pattern = #"(?<=(['"])\b)(?:(?!\1|\\).|\\.)*(?=\1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""2005014523","34.95661","-96.74025","1","52","52","5/17/2020 - 11:10 AM","By 5/17/2020 2:38 PM","5/17/2020 - 12:50 PM","UNPLANNED""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)