using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(['""])\b)(?:(?!\1|\\).|\\.)*(?=\1)";
string input = @"""2005014523"",""34.95661"",""-96.74025"",""1"",""52"",""52"",""5/17/2020 - 11:10 AM"",""By 5/17/2020 2:38 PM"",""5/17/2020 - 12:50 PM"",""UNPLANNED""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}