const regex = /(?<=(['"])\b)(?:(?!\1|\\).|\\.)*(?=\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=([\'"])\\b)(?:(?!\\1|\\\\).|\\\\.)*(?=\\1)', 'gm')
const str = `"2005014523","34.95661","-96.74025","1","52","52","5/17/2020 - 11:10 AM","By 5/17/2020 2:38 PM","5/17/2020 - 12:50 PM","UNPLANNED"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}