import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(['\"])\\b)(?:(?!\\1|\\\\).|\\\\.)*(?=\\1)";
final String string = "\"2005014523\",\"34.95661\",\"-96.74025\",\"1\",\"52\",\"52\",\"5/17/2020 - 11:10 AM\",\"By 5/17/2020 2:38 PM\",\"5/17/2020 - 12:50 PM\",\"UNPLANNED\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}