re = /(?<=(['"])\b)(?:(?!\1|\\).|\\.)*(?=\1)/m
str = '"2005014523","34.95661","-96.74025","1","52","52","5/17/2020 - 11:10 AM","By 5/17/2020 2:38 PM","5/17/2020 - 12:50 PM","UNPLANNED"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end