$re = '/\b(
(?:
(?:автомобиля\s{0,5})
(?:\w{1,25}\s{1,5}){0,3}\W{0,2}не)|
(?:
(?:ука(?:зать|жи(?:те|))[\s:,-]{0,5})
(?:\w{1,25}[\s:,-]{0,5}){0,5}наличие)
)\b/mixu';
$str = 'Просьба присылать подробное резюме с фотографией на почту, укажите: пожалуйста , наличие автомобиля.
Просьба присылать подробное резюме с фотографией на почту, укажите пожалуйста наличие автомобиля.
Просьба присылать подробное резюме с фотографией на почту, укажите,пожалуйста - наличие автомобиля.
наличие автомобиля не обязательно, не требуется
Наличие автомобиля не является обязательным.
Наличие автомобиля совершенно не обязательно.
Наличие личного автомобиля так же не обязательно
Наличие личного автомобиля не обязательно
Наличие личного автомобиля (не обязательно)
Наличие личного автомобиля-не обязательно
Наличие личного автомобиля - не обязательно
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);