import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"""
\b(
(?:
(?:автомобиля\s{0,5})
(?:\w{1,25}\s{1,5}){0,3}\W{0,2}не)|
(?:
(?:ука(?:зать|жи(?:те|))[\s:,-]{0,5})
(?:\w{1,25}[\s:,-]{0,5}){0,5}наличие)
)\b
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
Просьба присылать подробное резюме с фотографией на почту, укажите: пожалуйста , наличие автомобиля.
Просьба присылать подробное резюме с фотографией на почту, укажите пожалуйста наличие автомобиля.
Просьба присылать подробное резюме с фотографией на почту, укажите,пожалуйста - наличие автомобиля.
наличие автомобиля не обязательно, не требуется
Наличие автомобиля не является обязательным.
Наличие автомобиля совершенно не обязательно.
Наличие личного автомобиля так же не обязательно
Наличие личного автомобиля не обязательно
Наличие личного автомобиля (не обязательно)
Наличие личного автомобиля-не обязательно
Наличие личного автомобиля - не обязательно
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)