import re
regex = re.compile(r"""
\b(
(?:
(?:автомобиля\s{0,5})
(?:\w{1,25}\s{1,5}){0,3}\W{0,2}не)|
(?:
(?:ука(?:зать|жи(?:те|))[\s:,-]{0,5})
(?:\w{1,25}[\s:,-]{0,5}){0,5}наличие)
)\b
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE | re.UNICODE)
test_str = ("Просьба присылать подробное резюме с фотографией на почту, укажите: пожалуйста , наличие автомобиля.\n"
"Просьба присылать подробное резюме с фотографией на почту, укажите пожалуйста наличие автомобиля.\n"
"Просьба присылать подробное резюме с фотографией на почту, укажите,пожалуйста - наличие автомобиля.\n\n"
"наличие автомобиля не обязательно, не требуется \n\n\n"
"Наличие автомобиля не является обязательным. \n"
"Наличие автомобиля совершенно не обязательно.\n"
"Наличие личного автомобиля так же не обязательно\n"
"Наличие личного автомобиля не обязательно\n"
"Наличие личного автомобиля (не обязательно)\n"
"Наличие личного автомобиля-не обязательно\n"
"Наличие личного автомобиля - не обязательно\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")