#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[^ ]+ = [^;]*\.\w\(yj\.class, [^;]*\);)"
Local $sString = "c = kj.a(yj.class, ki.f); //Should match entirely" & @CRLF & _
"k = kj.h(yj.class, ki.b); //Should match entirely" & @CRLF & _
"Object a0 = this.l.a(yj.class, this.bo().b(0.5, 0.0, 0.5)).iterator(); // Should NOT match at all"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")