// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[^ ]+ = [^;]*\.\w\(yj\.class, [^;]*\);)").unwrap();
let string = "c = kj.a(yj.class, ki.f); //Should match entirely
k = kj.h(yj.class, ki.b); //Should match entirely
Object a0 = this.l.a(yj.class, this.bo().b(0.5, 0.0, 0.5)).iterator(); // Should NOT match at all";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}