re = /(^[^ ]+ = [^;]*\.\w\(yj\.class, [^;]*\);)/m
str = 'c = kj.a(yj.class, ki.f); //Should match entirely
k = kj.h(yj.class, ki.b); //Should match entirely
Object a0 = this.l.a(yj.class, this.bo().b(0.5, 0.0, 0.5)).iterator(); // Should NOT match at all'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end