const regex = /(^[^ ]+ = [^;]*\.\w\(yj\.class, [^;]*\);)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[^ ]+ = [^;]*\\.\\w\\(yj\\.class, [^;]*\\);)', 'gm')
const str = `c = kj.a(yj.class, ki.f); //Should match entirely
k = kj.h(yj.class, ki.b); //Should match entirely
Object a0 = this.l.a(yj.class, this.bo().b(0.5, 0.0, 0.5)).iterator(); // Should NOT match at all`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}