package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^ ]+ = [^;]*\.\w\(yj\.class, [^;]*\);)`)
var str = `c = kj.a(yj.class, ki.f); //Should match entirely
k = kj.h(yj.class, ki.b); //Should match entirely
Object a0 = this.l.a(yj.class, this.bo().b(0.5, 0.0, 0.5)).iterator(); // Should NOT match at all`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}