use strict;
my $str = 'c = kj.a(yj.class, ki.f); //Should match entirely
k = kj.h(yj.class, ki.b); //Should match entirely
Object a0 = this.l.a(yj.class, this.bo().b(0.5, 0.0, 0.5)).iterator(); // Should NOT match at all';
my $regex = qr/(^[^ ]+ = [^;]*\.\w\(yj\.class, [^;]*\);)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}