# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*//gm;t' <<< "some_txt
# → some_txt
[info1]some_txt
# → some_txt
[info1][info2] some_text
# → some_txt
[info1][info2] some_text_with_[___]_abc
# → some_text_with_[___]_abc
"