using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\[[^][]+](?:\s*\[[^][]+])*)?\s*";
string substitution = @"";
string input = @"some_txt
# → some_txt
[info1]some_txt
# → some_txt
[info1][info2] some_text
# → some_txt
[info1][info2] some_text_with_[___]_abc
# → some_text_with_[___]_abc
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}